• Welcome to Thousand Roads! You're welcome to view discussions or read our stories without registering, but you'll need an account to join in our events, interact with other members, or post one of your own fics. Why not become a member of our community? We'd love to have you!

    Join now!

Pokémon I Think I Bricked My PMD Darkness Cartridge

Help, anyone?

IFBench

Rescue Team Member
Location
Pokemon Paradise
Partners
  1. custom/chikorita-saltriv
  2. custom/bench-gen
  3. charmander
  4. snivy
  5. treecko
HEY SO WHAT THE FUCK???? Has anyone else encountered this, or is it just me? This is completely bizarre, and I can't find anything about it online.

I was playing my copy of PMD Explorers of Darkness. It's one of my favorite games, and this run I decided to go with Meowth and Totodile. Things went well, up until Dark Hill. See, I always have trouble with this dungeon. Gastly line is so annoying to deal with, especially as a normal-type.

Anyways, after one of my attempts, I decided to have my Meowth character just dance along to the music. It's something I often do when I'm bored in these games, have my character move in random directions in a free-roam area in time with the music.

Well, I got called away for something, so I shut my DS, and when I came back and opened it back up, my team was sinking in the small pool of water in the top of the area, using what I'm almost certain is the same animation used in Northern Desert.

This was a huge shock to me. In all my years of playing this, I'd never seen this before! Excited for new content in my favorite game, I eagerly awaited what would happen next.

Once my team had finished sinking, the screen went black, and a dungeon header showed up on screen: Murky River B1F.

The dungeon was mostly uneventful, but had a lot of water-type and ghost-type Pokemon. The graphics were similar to that of Stormy Sea in Rescue Team, but grayed out. Oddly, though, my team's hunger never got low. I checked the menu, and the hunger meters were completely gone!

After making it out of the dungeon, there was a free-roam area, covered in what looked like cracked ice. My partner began speaking, and I don't remember what exactly was said, but I'll try to paraphrase it.

Totodile: "Where are we? Where did you take us?"

Totodile: "Oh...you're right! Dusknoir won't find us here!"

Totodile: "Let's rest up here, then head back when we're ready. I'm sure I'll make it out of here with your help, Meowth."

I quickly headed onwards, eager to see what lie ahead. Another dungeon header showed up: Palace Ruins 1F.

It was a pretty difficult dungeon, and the graphics were similar to the free-roam area. Lots of greyed-out cracked ice. There wasn't any enemy Pokemon or items here, weirdly. It was completely barren, aside from my team.

Soon, I made it to the end of the dungeon. It was another free-roam area, though a small one. There was just an exit to the north, and a jumbled sprite in the corner. The game must have been starting to glitch out. There was only one line of dialogue here, and it actually came from the player character! They said "I have a bad feeling about this..." upon entering the area.

I pressed on ahead, and saw something absolutely crazy. I never played Gates, heard it was bad and not like Explorers, but I recognized the Bittercold. But it was here in Explorers! And it was absolutely massive, taking up most of the screen! What the fuck!

Just as weirdly, though, my Totodile partner disappeared. She was even gone from the top screen status.

The standard boss battle music began, and immediately, the Bittercold hit my Meowth character with something called "Desperation" for more damage than I remember, but more than enough for a one-hit KO. Even after their sprite disappeared, the message log didn't come up, though. I still had my turn! I tried to use Fury Swipes, and it did a good amount of damage.

Then, out of nowhere, Primal Dialga crashed down in front of the Bittercold, and the game started glitching like mad. Sprites were all jumbled up, the music turned to an awful, ear-grating blare, and the palette kept cycling. Trying to get the sound to stop, I turned the volume all the way down, but it still wouldn't stop. Even when I tried closing the DS it wouldn't stop.

When I opened it back up, the DS was on the home screen, but I couldn't launch Explorers back up, no matter what I did. I tried blowing the cartridge, restarting my DS, playing another game then trying to start back up Explorers, but nothing worked. Whatever this did seemed to irreparably brick my cartridge.

Anyone else seen anything like this in this game? Or at least an idea how to fix this? This game was my childhood, and I really don't want it to be broken. Explorers was the best game ever made.
 
Top Bottom